1
Vote

Bug in code for Firewall and support for Win8 and beyond

description

2 things I noticed:
  1. In CheckUPnPFirewallRules the code reads:
 if ((losVersion | OperatingSystem.WindowsXP) == OperatingSystem.WindowsXP)
Shouldn't it be:
 if ((losVersion & OperatingSystem.WindowsXP) == OperatingSystem.WindowsXP)
  1. OperatingSystem and GetOSVersion do not support windows 8 and beyond (or server). IT will return Unknown.

comments

TheToid wrote Oct 4, 2014 at 3:17 PM

Thanks rboy1, I will fix this :)